12 November 2018

ILT Department

The current release of SEQTA Engage uses features that require the more recent versions of web browsers. SEQTA's list of preferred browsers is

  • Mozilla Firefox, version 60 or newer
  • Google Chrome, version 66 or newer
  • Apple Safari, version 11 or newer
  • Microsoft Edge, version 41 or newer

Microsoft Internet Explorer 11 is flagged as old, and will not be supported from 2019.